Email delay
Incident Report for Cognito Forms
Resolved
This issue has been resolved, and any delayed emails should be sent shortly.
Posted Jun 03, 2021 - 11:35 EDT
Identified
Email notification delivery is currently delayed for HIPAA and verified email customers. This is an issue that has been identified and our email provider is currently working on resuming normal delivery as soon as possible.
Posted Jun 03, 2021 - 09:19 EDT
This incident affected: Email.