Partial Service Disruption

Incident Report for Cognito Forms

Resolved

The issue has been resolved, and all systems are operating normally. We appreciate your patience while we worked with our infrastructure partner to restore service.
Posted Apr 24, 2026 - 17:03 EDT

Monitoring

Service has been restored following the earlier issue with upstream infrastructure, and the site should now be accessible for all users. We will continue to monitor to ensure continued stability. Thank you for your patience while we worked through this issue.
Posted Apr 24, 2026 - 13:10 EDT

Identified

Our application and backend systems are operating normally, and we have confirmed this issue did not result from any recent changes on our end. The disruption stems from Microsoft Azure infrastructure responsible for routing traffic, which is causing some requests to fail.
We are working directly with Microsoft to resolve the issue as quickly as possible and will provide updates as we learn more.
Posted Apr 24, 2026 - 11:18 EDT

Investigating

Some users may be experiencing intermittent issues loading pages or submitting forms. We’re actively investigating and working to restore full service. Thank you for your patience—we’ll keep you updated as we make progress.
Posted Apr 24, 2026 - 09:05 EDT
This incident affected: Website and Forms.