Server Incident
Incident Report for Cognito Forms
Resolved
This incident has been resolved.
Posted Oct 12, 2019 - 21:01 EDT
Monitoring
Services should be now back to normal for all Cognito Forms users. We will continue to monitor the situation.
Posted Oct 12, 2019 - 19:34 EDT
Investigating
We are actively investigating a service outage affecting a number of customers and their forms. Normal services will resume as quickly as possible; we apologize for any inconvenience this may cause.
Posted Oct 12, 2019 - 17:32 EDT
This incident affected: Website and Forms.